Xcode8 pod install 报错 “Generating Pods project Abort trap: 6”

今天在写一个新项目的时候,使用cocoapods在执行$ pod install的时候,终端提示Generating Pods project Abort trap: 6

解决办法:

删除所有cocoapods gems,
依次执行以下命令:

sudo gem uninstall cocoapods
sudo gem uninstall cocoapods-core
sudo gem uninstall cocoapods-deintegrate
sudo gem uninstall cocoapods-downloader
sudo gem uninstall cocoapods-plugins
sudo gem uninstall cocoapods-search
sudo gem uninstall cocoapods-stats
sudo gem uninstall cocoapods-try
sudo gem uninstall cocoapods-trunk

然后安装最新发布版本:

sudo gem install cocoapods --pre

以上原文链接在这里
—————————–我是分割线—————————–

这时候有可能会提示以下错误:

ERROR:Could not find a valid gem ‘cocoapods’ (>= 0), here is why:

Unable to download data from https://ruby.taobao.org/ – SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (https://ruby.taobao.org/specs.4.8.gz)

原因是taobao Gems 源已停止维护,解决办法在这里

发表评论

电子邮件地址不会被公开。

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据